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HYPACK SHELL

• GeoJSON files are now supported in the HYPACK Shell, and can be displayed as a 
background file. 
> To add a GeoJSON file, in the Project Items tab, right click Background Files -> Add 

File -> GeoJSON Files. Select the desired file.

> To adjust the 
GeoJSON display 
options, make sure the 
GeoJSON file is 
selected (checkbox is 
checked). Right click 
the GeoJSON file -> 
Setup. The JSON 
Display Options 
window appears. You 
have the options to 
Adjust Line Color, Line 
Width, Fill Color, Fill 
Type. A sample of 
what your JSON file 
will look like appears 
on the right hand slide 
of the window. Click 
[OK] once you have 
selected your display 
options.
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> GeoJSON files are compatible with the Info Query tool. To view GeoJSON attributes, 
in the Map window, click Draw -> Info Query, which opens the Info Query window tab 
on the left side.

• To reduce user confusion in the Settings window, the Hide Soundings Above Safe 
Contour option has been moved from the Charts tab to the Soundings tab under 
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the Options section. This Settings window is accessed from the HYPACK Shell -> 
Settings -> Settings.

• Added a new menu item for the Channel Wizard Preparation->Editor menu in the shell. 
This item will support opening the New Channel Wizard tool.

• New tool added to process GNSS/INS data using Qinertia in HYPACK.
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• eHydro renamed to USACE Metadata and moved from Tools to Utilities -> File Work -> 
USACE Metadata.

USACE Metadata can also be accessed from the Save Survey menu in MBMAX64.

• Geodetic Parameters: Added SQL code to pull Datum Transformation values from 
the EPSG database based on the active EPSG code.

Added an EPSG button in Datum Transformation area of the GeoPar dialog that opens a 
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list of transformation parameters extracted from the EPSG Database. The user can select 
what is most appropriate for their situation.
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NEW PROGRAM: REMORA

Remora is a help program that pulls from HYPACK help files and connecting to the internet 
using AI attempts to come up with answers for the user. Located in the HYPACK Shell under 
Help -> Remora. Here is a sample output:

NEW PROGRAM: DREDGE MONITOR

Dredge Monitor program added to Survey -> Dredge Monitor. This supports our new 
HYPACK LINK product.
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HARDWARE

SURVEY DEVICE DRIVER UPDATES

• ADCP.dll (ADCP Driver):

The ADCP driver now supports the Nortek Signature and Nortek Nucleus series. Nortek 
Signature is now a dropdown option in the driver setup window. When selected, the user can 
choose to enable the Use as multitransducer checkbox. When checked, the driver outputs 
two values: The average depth value of all four 25 degree slant beams, and the vertical beam 
depth.

For the Nortek VM Software Setup, in the Output Section, select “AD2CP with embedded 
NMEA” for Format, and “Network” for Destination.
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• The Kongsberg KMALL Setup window has a 
new option called Log KMALL SV Profile (not 
Recommended). Checking the box next to this 
option enables using the SVP logged by the 
Kongsberg device.
To enable or disable logging the KMALL SVP: 

1. From HYPACK Shell, click Preparation -> 
Hardware Setup. The HYPACK Combined 
Hardware window appears.

2. In the HYPACK Combined Hardware window, 
open the Mobile tab, and under the Device Type 
section, select HYSWEEP Devices.

3. From the Manufacturer/Model list, click 
Kongsberg KMALL and click [Add -->]. 
Kongsberg KMALL will appear in the Installed 
list.

4. Double click Kongsberg KMALL in the Installed 
list. The Kongsberg KMALL Setup window 
appears. Check or uncheck the Log KMALL SV 
Profile (not Recommended) checkbox as 
needed.

• New Driver: CEE Hydro CEE-LINE (CEELINE.dll)
Logs depths and a bin file.
Select between 1 Channel or 2 Channels in the Setup dialog.

The device window in HYPACK SURVEY is similar to CEESCOPE's device window. One 
window per channel appears depending on the selection in HYPACK Hardware setup, 
and each window displays time, depth, draft, index, scale width, end of scale, and scroll 
speed (ms).

• Magnetometer Interface (Magnet.dll): Now supports Marine Magnetics Synapse 
device format (ASCII), which is added as a new device option in the Magnetometer 
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Interface driver (magnet.dll) setup window. This device logs Gamma, Depth, Altitude 
and Depth+Altitude values. 

Here is the Marine Magnetics Synapse setup window in HYPACK Hardware.

> Auto-Start Synapse Display: Check to enable this option. When enabled, the Marine 
Magnetics Synapse window automatically launches when HYPACK SURVEY is 
started.

> Synapse Array Magnetometer Count: Set number of magnetometers in the Synapse 
array. Supports up to 30.

> Start/Stop logging in survey.exe to log magnetometer data into the RAW file as SMI 
values. These can be loaded into the Magnetometer Edit program and visualized. 
Data is also populated in the Spreadsheet in Magnetometer Edit.
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Open the Marine Magnetics Synapse window in HYPACK SURVEY by clicking [Synapse] 
in the Magnetometer Interface window.

Here is the Marine Magnetics Synapse window in HYPACK SURVEY. 
You can select the desired node and configuration, and enable or disable peripherals 
including Magnetometer, Pressure/Depth sensor, Altimeter, and IMU.

• New Driver: Autonomous Vessel Command (MotherShip.dll)
Allows users to set up single or multiple autonomous vehicles (ducklings). This driver 
passes waypoint information to up to 10 duckling vessels. There are two modes of 
operation:

Single Duckling Mode - When only a single duckling follows the Mother Ship, the edge of 
the swath can be used as a distance from the Mother Ship.
January / 2026  11



In the Transit Mode, the driver uses a smoothing method for the training path.

Multiple Duckling Mode - Ability to present up to 10 ducklings with waypoints so that the 
Mother Ship controls all of the vessel paths.

The ducklings need to receive the logging command from the Mother Ship so that the 
ducklings all log data along with the Mother Ship.

No setup in the HYPACK Hardware required. Setup is done in the Autonomous Vessel 
Command window in HYPACK Survey.

• NMEA.dll - Added new check box to allow parsing of XDR NMEA sentences in the 
NMEA Input/Output Driver Setup window. High frequency and low frequency depths 
are parsed and displayed in the Data Display window of survey. They are also logged in 
the RAW file as EC2 (dual frequency) depth records. You can select this option by going 
12



to Preparation -> Hardware Setup, add nmea.dll, then double click the driver to bring up 
the setup window.
Note that the default depth values are output in meters, therefore we convert this data to 
feet when using a foot grid in Geodesy.

• Posmv.dll (Applanix POS M/V): Posmv.dll has received a couple of updates:
> Use GSOF Messages checkbox removed from the Applanix POS M/V Setup 

window. GSOF messages are no longer supported or used.
> Three more Record multibeam frame data message options have been added 

for Group 103, 120, and 121.
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• SIDUS Rotator (sidus.dll): Start Logging on Scan checkbox added. If the box is 
checked the driver will automatically begin logging when the sweep button is checked.

• Subbot.dll (Sub-bottom Driver): Driver now marks an event when SSC string is 
received from a Fugro Starfix.

• New drivers: SwatchReceiver.dll and SwathSender.dll
Used to share MBES data over the network.

HYSWEEP DEVICE DRIVER UPDATES

• Applanix POS M/V Network: All GSOF message options removed from the Applanix 
Network Driver Setup window. GSOF messages are no longer supported or used.

• Kongsberg KMALL: Removed the 'Reverse Raw Beam Angles' checkbox from the 
Kongsberg KMALL Setup window. HYPACK® now automatically handles raw beam 
angles by using RX and TX orientation from K-Controller installation parameters. 
Previously, the checkbox in the driver setup window was used to designate the RX and 
TX angles, however Kongsberg configurations may be RX forward/reversed and TX 
forward/reversed, and the checkbox only handled two of the cases (forward-forward and 
reversed-reversed).
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The left image shows how the Kongsberg KMALL Setup window looked previously, the 
right image shows the updated version.

• New Driver: GeoAcoustics GeoBeam
GeoAcoustics GeoBeam uses the Hydro-Tech multibeam hardware, so refer to the 
Hydro-Tech Multibeam section in the HYSWEEP Interfacing manual.

Log Datagrams (*.HYTEM): This box is unchecked by default and usually not required. 
When checked, the driver logs raw datagrams to a *.HYTEM file to help with debugging. 
HYTEM is the Hydro-Tech datagram format.

Use Pass Through Position, Heading and MRU: This box is checked by default. When 
checked, heading and motion datagrams from the embedded IMU are parsed and then 
logged to an *.HSX file. Position data is passed to the HYPACK® Survey driver 
Hysweep_Extended.DLL. Hysweep_Extended.DLL is an optional and very basic GPS/
INS driver which can be used to replace the native device driver (POS MV.DLL for 
example).

• NORBIT Dual Head: For the Norbit LMD system, the driver now logs beam detection 
priority values (1-15) to HSX files. Highest priority = 0, lower priorities = 1, 2, 3, etc. This 
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helps determine whether high or low frequency is used in the XYZ output. This is 
important to know because high and low frequency are overlapped for a ping. Low 
frequency finds the hard bottom and should be used when valid. When low frequency is 
not valid, high frequency provides better resolution and should be used. Similar to dual 
frequency single beam echo sounder.

• Ouster OS-1: The Ouster OS-1 driver has received a few updates:
> This driver now supports up to version 3.x+ of the firmware.
> There are two driver options to select from: Ouster OS-1 (Horizontal) and Ouster OS-

1 (Vertical). Select Horizontal or Vertical depending on the device's orientation - the 
Ouster Setup form has the same parameter options for both.

> The Ouster Setup Dialog has a new option: NMEA Ignore Valid Character. Use it to 
set whether or not to accept standard NMEA $GPRMC UART messages/timestamps. 
These messages are a common way for GPS systems to share timestamp 
information in UTC time format. This option is set to True by default.
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DREDGEPACK DEVICE DRIVER UPDATES

• New Driver: sidus.dll (Sidus Rotator Driver)
> Sends commands through either a serial or ethernet connection.
> Allow the user to set limits both port and starboard to prevent cable damage, store the 

settings in the INI file.
> Provide a graphical view showing the direction the rotator is pointed and update with 

every request.
> Provide a go home function, to return the Sidus to the resting position.
> Provide an emergency stop option to prevent further movement in any direction.
> Refer to the manual "MBES for Marine Construction and Dredging - Sidus Rotator 

Driver" (Sidus Rotator Driver_DRVSU-001 Init.pdf) for additional information.

SIDE SCAN SURVEY

• The Range and Height sliders in the New Target window have been changed to 
Shadow Start and Shadow End, respectively. This update was made to reduce 
confusion for users when calculating shadow size by matching the terminology used by 
HYPACK instructors.

Additionally, all three slider colors (Altitude, Shadow Start, and Shadow End) are now red 
to be visually distinct from the signal amplitude.
To view the New Target window:

1. From the HYPACK Shell, click Side Scan -> Targeting and Mosaicking (Beta). The Side 
Scan Targeting and Mosaicking Beta window appears.

2. Click File -> Open and select your desired RAW or LOG files. The Catalog window 
appears.

3. In the Catalog window, select the files you want to open, then click [Select]. To open all 
files, click [Select All].
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4. Once the files are open, click the Scanview tab, and double click the location on the side 
scan image you would like to create a target. The New Target window appears, which 
allows you to view target parameters, classify, compare targets, make notes, and save 
the target and image.

TARGETING AND MOSAICKING

The Side Scan Targeting and Mosaicking (SSTM) Beta program is now the main 
Targeting and Mosaicking program.

• "Targeting and Mosaicking (Beta)" is renamed "Targeting and Mosaicking"
• "Targeting and Mosaicking" is renamed "Targeting and Mosaicking (Legacy)". 

For additional resources on the current version of SSTM, refer to the following articles:

• New Side Scan Targeting and Mosaicking Transitions Out of Beta by Daniel Tobin
• Creating Targets in Side Scan Targeting and Mosaicking by Jocelyn Kane
• Real-Time Side Scan Mosaic by Daniel Tobin
• Segmentation in Side Scan Targeting and Mosaicking by Daniel Tobin
• Backscatter Update for Side Scan Targeting and Mosaicking by Daniel Tobin
• Side Scan Targeting and Mosaicking Beta Speed Improvements by Daniel Tobin
• Targeting and Mosaicking Walkthrough by Daniel Tobin

A new Targeting and Mosaicking section will be available in the HYPACK 2026 manual.

HYSWEEP® SURVEY

64-BIT HYSWEEP® EDITOR (MBMAX64)
• Added the storage of geodetic information into HS2X files. Copies over the 

information from HSX files if it exists. Otherwise, it includes the project geodesy. If loading 
an HSX or HS2X file with geodesy information, the report will include that geodesy 
information. Otherwise it will include the project geodesy.

• The 'Channel Plan' option under the Show section now only affects whether any 
enabled channel plan files (*.CHN) in your project are displayed in the main 
MBMAX64 survey map window. Note that channel plan files show up in the Profile and 
AB Cross Section windows regardless whether Channel Plan is enabled/disabled in the 
Show settings. This change was made because channel plans can completely cover 
soundings and be distracting in the survey window, but are still useful to display in the 
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Profile and AB Cross Section windows.

For reference, here is the channel plan overlay in the Profile window.

• The Save Image to File button has been added to the A-B Cross Section Patch Test 
window, Cloud window, Cloud Popup window, and the Imagery window. This button 
allows users to save the display window to a *.bmp, *.jpg, or *.png file.

To open these windows, run MBMAX64, load your survey files, then click the Stage 2 
(Depth Editing) buttons. All four of these windows are enabled in Stage 2 editing.
> A-B Cross Section Patch Test is opened with the wrench button in the Edit section at 

the top of the MBMAX64 window.
> Cloud is opened with the [Cloud] button in the left Edit section under the Stage II 

column.
> Cloud Popup is opened with the cloud button in the Edit section at the top of the 

MBMAX64 window.
> Imagery is opened by going to the left Edit section under the Stage II column, then 

clicking [More Windows] -> Imagery.
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Updated A-B Cross Section Patch Test Window

Updated Cloud Window
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Updated Cloud Popup Window

Updated Imagery Window

• Added a new CoordinateUtils feature that allows a user to copy their cursor 
coordinates in MBMAX64 to the clipboard or open Google Earth at their cursor 
coordinates.
> Accessed via the Edit dropdown menu in MBMAX64.
> Coordinates at the current cursor are converted to DMS format.
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> Only works when in Phase 2.
> Launch Coordinates in Google Earth: This option brings the user to the location of 

the coordinates. Clicking in the Google Earth search text box in the upper left will add 
the coordinates to this text box and pressing enter or “search” will display the pin and 
coordinates on the Google Earth map.

> Other option is Copy Coordinates to Clipboard, which allows users to copy the lat-
lon values and paste into a text file.

• Added the ability to use filters in MBMAX64 for depth and max angle (port/stbd) 
that were set in survey.
> Open MBMAX64 and load multibeam lines (HSX files).
> Click on the "Search and Filter Options" to open the filters dialog.
> Select the "Basic" tab.
> Near the bottom of the Basic tab is a new checkbox, "Use HYSWEEP survey filters."
> Next, click on update and any depth, horizontal offset or max beam angle filters 

applied during data acquisition will be applied to the data.
> Unchecking the box and clicking Update will revert back to default values.

SONAR PROCESSING WINDOW UPDATES

Two new options are now available in the Sonar Processing Window: “Ignore Quality Codes” 
and “Extrapolate SVP Using Full Ocean Model”.

• Added the Ignore Quality Codes checkbox to the Sonar Processing window. Ignore 
Quality Codes allows users to decline using logged quality codes to determine if 
soundings are displayed or not in MBMAX64. While checked, the program ignores the 
quality codes logged by the sonar, and all logged data is shown. While unchecked, 
soundings with 0 (reject soundings) as the quality code are not displayed. Once selected 
files are loaded, Ignore Quality Codes is greyed out.

To use this new feature:
1. From the HYPACK Shell, click HYSWEEP -> HYSWEEP Editor. The MBMAX64 window 

appears.
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2. In the MBMAX64 window, click File -> Load Survey, and select your HSX or LOG file and 
click [Open]. The Read Parameters window appears.

3. In the Read Parameters window, go to the Processing tab and click [Sonar…]. The Sonar 
Processing window appears.

4. In the Sonar Processing window, select your sonar model from the Sonar ID drop down 
menu, and check or uncheck Ignore Quality codes. Click [OK].

• Added the Extrapolate SVP Using Full Ocean Model checkbox to the Sonar 
Processing window.
This allows users to choose what SVP values they want to use beyond the range of their 
SVP sensor's measurements. Previously, HYPACK® used calculated values from its full 
ocean model, which is described below.

To use this option, check the Extrapolate SVP Using Full Ocean Model checkbox to use 
our ocean SVP model beyond the maximum working depth of your sensor, and uncheck it 
to extend the value of the last SVP measurement to the bottom. Extrapolate SVP Using 
Full Ocean Model is unchecked by default, and the last SVP reading is extended to the 
bottom, which is more appropriate for shallow water surveys. However, note that neither 
option will change sounding values from shallow water (harbor, river, etc.) surveys, since 
SVP measurements are used throughout.

Sound velocity at different water depths can be measured in shallow water surveys using 
a sound velocity profiler. However, maximum working depths for standard SVP sensors 
commonly range from 300m to 500m, with certain deep sea models that have a cast 
length a of a few thousand meters. To estimate sound velocity beyond the maximum 
working depth or reach of a surface cast, HYPACK® uses a full ocean model. Note that 
HYPACK® has always extended the last SVP reading an additional 25m before using the 
ocean SVP model. For more information on how calculations are made in the full ocean 
model for medium and deep water surveys, and the reason for its usage, refer to 
Estimation of the Ocean Sound Velocity Profile by Mike Kalmbach ( https://
www.xylem.com/siteassets/brand/hypack/resources/newsletter/2008/estimation-of-the-
ocean-sound-velocity-profile.pdf).
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ADDITIONAL DATA PROCESSING

MAGNETOMETER EDITOR

• HYPACK® now supports data obtained from the RTSYS COMET-MCM 
magnetometer, which is recorded in a *.txt file that is called a Comet-Mag file.

Data strings for this file type are in the following format:
AUV time, Latitude (degree), Longitude (degree), altitude (m), sensor 
time, magnetic field, signal strength, depth, leak sensor, measurement 
time, signal quality, warning messages

To open a Comet-Mag file, from the HYPACK Shell, click Processing -> Magnetometer 
Editing. The Magnetometer Editor window opens. Click File -> Open, the File explorer 
opens. From the file type dropdown menu, select the Comet-Mag Files (*.txt) option, 
select your file, and click [OK].

NEW TOOL: VECTOR MAGNETOMETER CALIBRATION FORM.

We’ve added the Vector Magnetometer Calibration Form, which allows users to 
calibrate vector (fluxgate) magnetometer data. Users can define up to two figures of merit 
on the data track line, which the program uses to calculate corrections for sensitivity 
(S1,S2,S3), non-orthonality (U1,U2,U3), and offsets (O1,O2,O3). These corrections are 
saved to a *.txt file and applied to the magnetometer data.

To use the Vector Magnetometer Calibration Form:

1. From the HYPACK Shell, click Processing -> Magnetometer Editing. The Magnetometer 
Editor window opens.

2. Load your vector mag files using File -> Open, and set up the read parameters.
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3. Click Tools -> Vector Magnetometer Calibration. The Vector Magnetometer Calibration 
window opens.

4. You may define up to two figures of merit (FOMs) on the track line for magnetometer 
vector calculations. Define the first FOM by clicking the start and end points on the track 
line in the Magnetometer Editor display window. To add a second figure of merit, check 
the Include Area 2 checkbox, then click on the track line to set the start and end points. 
Selected areas on the track line will be highlighted in white, and the point values of each 
starting or ending point will be displayed in the box to the right of each variable.
a. Note: The button to the left of each point can take on one of two states: [Set Start] or 

[Set End], and [Selecting…]. Click [Set Start] to select the starting point of an area. 
Click [Set End] to select the end point of an area. While you are actively defining the 
start or end point, the button will show [Selecting…].

b. Click [Clear] to remove all selected start and end points to begin defining the areas 
again. Calibrated data values are also removed.
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5. The [Calculate] button is enabled once the areas are defined. Click [Calculate] to run the 
Orsted calibration on the selected data to find the calibration parameters, which are 
applied to the data. Once the calculation is finished, “Done” is shown to the right of the 
[Calculate] button.

6. Click [Export]. The calibration parameters are saved to a *.txt file. Calibrated data is 
added as Corr. Magnetic Field value in spreadsheet, profile window, and save options.

7. Switch to the spreadsheet and add the Corr. Magnetic Field column to see the calculated 
value.

8. Save to XYZ or ALL with Corr. Magnetic Field as the Z Value.

FINAL PRODUCTS

EXPORT PROGRAM

• In the EXPORT program under the Options window, added the Export Line Name 
checkbox, which allows users to export line names from edited files (ie: HS2X, 
ALL) to DXF/DWG charts.

To use this new feature:
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1) From the HYPACK Shell, click Final Products -> Export.
2) In the Export window, click File -> Options.
3) In the Options window, click CAD Parameters -> Tracklines to open the CAD 
Tracklines Parameters tab. 
4) Check or uncheck the Export Line Name box. Set the size of the text using the Text 
Height (m) field.

The following image shows an example of DXF file generated by the CONVERT program.  
The line names are at the end of each line and circled in red.

HYPLOT MAX

• Users can now adjust the font used for soundings in HYPLOT MAX. To use this new 
feature, open HYPLOT MAX (Final Products -> HYPLOT MAX), click on the sheet name 
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under Items, and in the Properties section click Settings -> Soundings -> Font and the 
three ellipses […]. The Font editor window appears.

• Users can now rotate text boxes by entering an angle in the Rotation field. 
Previously, text could only be displayed horizontally or vertically using the Orientation field 
options.
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