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SOUNDING BETTER! NEWSLETTER
HYPACK® 2023 Release Notes
by Caroline Liu
This document covers changes that have been made since the HYPACK 2022 Release.

HYPACK INTERFACE (SHELL)
• The HYPACK Quarterly Update information has been added to Help --> About.

• The Shell now detects and displays Esri TIF files using HYPACK color tables. In an 
Esri TIF file, each pixel of data is a depth value instead of an RGB value. HYPACK® 
displays the Esri TIF by converting each depth value to a color based on the active color 
table selected by the user. After loading, the Messages window will display the minimum 
and maximum depths in the file, which you can use to help in setting up a color table.

To display an Esri TIF file:
1. Add the TIF file to your project. From the Project Items list, right click Background 
Files --> Add File --> TIF Files --> Select your file and [Open] the Esri TIF. The file will be 
added under Background Files.
2. Enable the Esri TIF file by checking the check box next to the file name.
3. Center the Esri TIF in your window by right clicking the file name --> Zoom Extents.
4. Open the Messages window to view the minimum and maximum depths by 
clicking View --> Messages.
5. Set a color table to display the depths by clicking on the Sounding Colors tab --> 
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click [Select Color Table]. Click Edit to bring up the Color Table Editor, which shows the 
depth values that each color corresponds to.

In the following example, the depths of this TIF file range from 1.74 m to 48.62 m, which is 
well-represented by the range of color bands available in the adcpviewer.hcf color table. 
Depending on the dataset, you may need to try out other color tables or create your own 
to accurately represent your data.

• Users can now set the orientation of target text labels from the Targets tab in the 
Settings window. The label can be positioned left, right, above, or below the target 
symbol, or the user can set a specific angle between 0 and 360 degrees, where 0 
degrees is directly above the target. These options are available for both Circle and Alarm 
targets. Set the rotation and position of target labels from Settings --> Settings and click 
the Targets tab.

The examples below show how target labels are oriented at a user-defined angle for 
Circle and Alarm target displays. Note that the label text for circle targets is rotated 
radially around the target, whereas the text remains upright for alarm targets. For circle 
targets, select any of the preset orientations (Left, Top, Right, Bottom) to display the 
2



target text upright.

• Users can now set a transparent chart color by using an eye dropper tool 
and clicking on the chart. This new tool is called “Select Transparent Color by 
Clicking in Map Window”. To select a specific chart color as the transparent color, 
from the Project Items list right click on the background chart, matrix file, or border file, 
and click “Transparency” to open the Set Transparency window. Make sure the 
“Transparent Color” box is checked, and that the Transparent/Opaque bar is pulled all the 
way to the right to Opaque. Click “Select Transparent Color by Clicking in Map Window”, 
and click on the colored region on the map that you want to set to transparent. Click 
[Apply] or [OK] to apply your changes.

Only one color is transparent at a time: For instance on a map, if you first selected the 
brown color of the land then selected the blue color of the water, the brown will reappear 
as opaque while the blue regions will become transparent. While the box next to 
Transparent Color is checked, the selected color will be transparent. Uncheck 
Transparent Color to display the original chart without affecting the transparency status of 
the selected color. 

To deselect the selected transparent color, click “Select Transparent Color by Clicking in 
Map Window” and click on the region with the color you want to be opaque again. Click 
[Apply] or [OK] to finish deselecting the color and have that color revert back to no 
transparency.
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No Transparency (Left), Colors Corresponding to Land (Right) and Water (Bottom Set as Transparent

• If a Sound Velocity Correction (*.vel) file contains location data, it is now marked in 
the map window as a blue circle. Make sure to check “Sound Velocity Files” in the 
Project Items list on the left to display the locations of *.vel files. Mousing over a displayed 
file outlines the blue circle in red, informing the user they may click on it. Clicking on the 
circle opens a window showing the file name, time and date, and a list of the depth/sound 
velocity entries. An [Open] button also appears at the top of the window. Click [Open] to 
open the selected *.vel file in the Sound Velocity program.

In the following example, the top image shows two *.vel files marked on the map. Notice 
that the selected *.vel file is displayed as a blue circle outlined in red.
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The next image shows a map from an example project with multiple *.vel files marked in 
the window.

• The Border Editor now displays the distance and angle relative to the next border 
point when dragging a point on the map window. The “next border point” is 
determined by numerical order, with point #1 as the next point for the very last point in the 
series. The angle is measured with the next point as the origin, where 0 degrees is 
located below the next point and the angle increases clockwise. 

In the example on the left, point #4 is located 335.88 ft and 12 degrees relative to border 
point #1. Since point #4 is the last point in this border, point #1 is its next border point.

In the example on the right, point #2 is being repositioned. Point #2 is currently located 
82.99 m and 270 degrees relative to its next border point (point #3).

To see this feature, open the Border Editor by clicking Preparation --> Editors --> Border 
Editor, then click the Cursor icon to set points by clicking in the map window. The distance 
and angle will appear as you hold and drag a new or existing point.
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• The Compress Project window has been simplified. The list of item types and check 
boxes has been removed, and users will now need to check/uncheck items from the 
Project Items list in the Shell to designate which files are enabled. Users can easily 
interact with the Project Items list while this window is open.

The Compress project window now only has the “Compress Only Enabled Files” option. If 
it is checked, only checked (enabled) files in the Project Items list will be saved to the zip 
file. If this option is unchecked, all project and externally referenced files will be 
compressed.

To compress a project:
1. Click File --> Compress Project.
2. In the Project Items list, check the file types or individual files that you want to save, 
then check “Compress Only Enabled Files”. 
Otherwise, leave the box unchecked to save all project files. 
3. Click [Compress], navigate to the folder you want to save your zip file, give your zip file 
a name, then click [Save]. The status bar of the Compress Project window will display the 
path and percent of the project saved. Once finished, you will receive a “Compression 
Complete” notification.

• Externally referenced files (which are files outside the current project folder) are 
now included when compressing a project. The zip file will preserve the original folder 
structure that each externally referenced file is saved under. For example, if a referenced 
file was saved to the Desktop, the referenced file will be saved to the zip file under a 
folder structure of Users\<Username>\Desktop.

Externally referenced files will not be included in the compression if “Compress Only 
Enabled Files” is checked while the referenced files are unchecked in the Project Items 
list.

• Users can now reposition targets in the HYPACK® Map window by clicking and 
dragging them. While the Add Target tool is selected, mousing over an existing target 
will draw a red circle inside or around the target, depending on scale of the map. 

To move a target:
1. From the Map View tools on the right of the Map window, click the 

Add Target icon.  
2. Mouse over the target of interest and make sure that the red circle appears.
3. Left click the target and drag to the desired position. A red line will connect the current 
position of the target to the position of the mouse while the left mouse button is held 
down.
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4. Release the left mouse button to drop the target in its new position.

Note that the process for adding new targets remains the same as long as an existing 
target is not highlighted with the red circle.

• Data within the boundaries of a matrix are now kept by default when users resize 
and save a matrix file in the Matrix Editor. Previously in the Matrix Editor, Save As and 
Save would either create or overwrite an existing matrix with a new empty matrix. Now, 
users can adjust the matrix boundary, cell size, and rotation, then select File -> Save or 
Save As to remap data from the original matrix to the current matrix settings. Save will 
save the updated matrix settings to the currently selected matrix, and Save As saves the 
current matrix to a new file.
In the following example, Hal.mtx (top image) is the original matrix. The matrix (light 
green border) is resized and rotated, then File -> Save As was selected to create a new 
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matrix named Hal_NewMtx.mtx, while also saving data from Hal.mtx that are within the 
boundary of the new matrix (bottom image).
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• Added the Save Empty Matrix option to the Matrix Editor because Save As and Save 
no longer create or overwrite an existing file with an empty matrix. 

To create a new empty matrix, go to File -> Save Empty Matrix, type in the new matrix file 
name, then click [Save]. If the user saves the new matrix in the current project, the matrix 
name appears in the Project Items list under Matrix Files.

To overwrite an existing matrix file with an empty matrix, go to File -> Save Empty Matrix, 
then select the name of the file to overwrite and click [Save].

•  Users can connect parallel offset lines in a “Z” pattern for autonomous vehicles, 
where the end of one line connects back to the beginning point of the next line. To 
do this, from the Line Editor click Offsets, then in the Parallel tab, set your line parameters 
and click “Connect Lines (For Autonomous Vehicles).”

• In the Edit Log File window, users can sort available data files by file name or date 
of creation. From the Shell, in the Project Items list right click on the LOG file you’d like to 
edit, then click Edit Log File. Within the Edit Log File window, right click the Available Files 
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list and select Sort by Name or Sort by Time.

• When exporting DXF contour files to KMZ, contour labels and line data are also 
exported and viewable within Google Earth.

To export a DXF file to KMZ, from the Shell go to the Project Items tree view. Make sure 
the DXF file you want to export is checked/enabled. Right click in the Project Items tree 
view and click Export to Google Earth. In the Export Items list, make sure the DXF File is 
checked. Click [Export], name your KMZ file, then click [Save]. 
You can share and open your KMZ file in Google Earth, which will overlay the contour on 
its recorded location on the map.

• Added the Lighting submenu option to the Shell, where adjustments apply to 
matrix files. These options are similar to the Survey lighting options for Matrix files. Open 
10



Widgets -> Lighting, and adjust values in the OpenGL Lighting window. 

• HYPACK Live Chat has been removed from the Help menu. If you need to contact 
HYPACK support, please call us at 1 (860) 635-1500.

NEWLY SUPPORTED FILE TYPES
• BAG Files are now displayed in HYPACK Shell. 2D GDI, 2D Mix, and 3D BAG files 

are supported.

To open a BAG file, from the Project Items tree view, go to Project Files folder -> 
Background Files.
> To invert the z-values in the BAG file, right click on the BAG file name and 

select Invert Depths. If Z-values are positive they are in depth mode, and inverting 
these values will effectively switch them from depth to elevation mode. Note that Z-
values do not auto-invert when the BAG file is loaded in depth mode configuration.

> To set the color palette to fit the depth or elevation range, right click on the BAG 
file and select Auto Scale Colors.

> Color table overrides for BAG files are supported. To select an alternate color 
table, right click on the BAG file name and select Set Color Table.

The Bathymetric Attribute Grid (BAG) file type is the standard for the National Ocean 
Service (NOS) hydrographic data files. BAG files contain XML metadata and two 
Layers in a matrix format-one of elevation and another uncertainty. Also contained is a 
list of post file creation edits to the data.

• Bucket Files Updates: Bucket files are drawn in the HYPACK Shell.
> We've added the option to turn a loaded bucket or shape file off or on in the 

Shell. To draw a bucket/shape file in the HYPACK Shell, from the Project Items list 
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right click file name, click Draw Style, then click Display shape so that a checkmark 
appears. To hide the shape, click Display shape so the checkmark disappears.

> Bucket settings are synced from the HYPACK Shell to DREDGEPACK, however 
changes in DREDGEPACK are currently not reflected in the Shell.

Users can now display Depth/Elevation, Date/Time, or Text for bucket (*.bkt) files in the 
Shell. To do this, from the Project Items list, navigate to Project Files and right click the 
Bucket Files folder. From the menu, navigate to Display Label and select from the options. 
The image below shows what None (upper left), Depth/Elevation (upper right), Date/Time 
(lower left), and Text (lower right) look like. These will only work if Draw Style “Hollow” or 
“Solid” is selected. The date will only display if the bucket file has the date file naming 
convention M(M)_D(D)_YYYY.bkt or MMDDYYYY.bkt.
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SOFT LICENSES
• Users can now choose to enable or disable loading their 

list of soft licenses. This is useful for any users who have 
experienced security issues with our soft licensing, which we 
are working to address. To disable (or enable) soft licenses, 
go to Settings --> License Manager, then click File --> Enable 
Soft License. 

When “Enable Soft License” is checked, the Soft License tab 
is shown along with information related to the license when 
the License Manager is opened (Left). When Enable Soft 
License is unchecked, the License Manager window displays Client Config tab (Right).

SOUNDING COLORS
Previously, color table files could only be saved or opened from either the Project or 
Shared (HYPACK Store, C:\HYPACK Store\Color Tables) folders. Now users can add, 
edit, and save color table files from other folders.
• Select Color Table - In the Select Color Table dialog, right clicking on the Project or 

Shared folders and selecting Add Group allows you to add other user-defined 
folders that contain color files (*.hcf). Once you’ve selected your folder from the file 
explorer and clicked [OK], that folder and all color files contained within are added to the 
bottom of the Select Color Table tree view. This allows color files residing in any folder to 
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be used in the Project.

These user-added folders can be removed by right clicking the name of the folder and 
selecting Delete Group. Note that you will be unable to delete the Project or the Shared 
folders.

Access the Select Color Table dialog from the Shell by clicking the Sounding Colors tab -
> [Select Color Table] button.

• Color Table Editor - Removed the Open (Shared), Save (Shared), and Save As 
(Shared) menu items. Open and Save As now open a dialog where you can set the 
file name and select the folder (Project or Shared folder) the file is in or will be saved to. 
You can also select either the Project or Shared folder and click Browse to open that 
folder. Any additional folders added by the user in the Color Select Dialog will also be 
included in the Folder drop down (bottom image).

Access the Color Table Editor from the Shell by clicking the Sounding Colors tab -> [Edit 
Color Table] button.
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Save will simply update the file on the disk if it is already associated with a file name, or 
will behave like Save As was clicked if no file name association exists yet.

PREPARATION

GEODESY
• Geodesy Settings can now be loaded from HSX or RAW file headers. To do this, from 

the Shell click Preparation --> Geodetic Parameters to open the Geodetic Parameters 
window. Then, click Tools --> Import HSX/Raw Data and select the *.raw or *.hsx file with 
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geodesy settings you want to use. HYPACK will notify you if the file does not contain 
geodetic data.

• Grid Conversion Dialog - minor updates:
> Window is sizeable.
> Pressing the Enter key is the same as clicking [Convert].

• In the Geodetic Parameters window, the options Load Custom Grid and Save 
Custom Grid have been added to the File menu. Loading and saving custom grids 
behaves the same as saving to the active project, meaning all settings are saved and 
restored (ex: RTK options). Note that the name of the custom grid file is only shown if 
Grids is set as User Defined.

NEW! GEOID FILE CONVERTER
The GEOID File Converter program allows users to import geoid models, then export them as 
HYPACK *.geo or ASCII Text files for use in HYPACK Geodesy. The GEOID File Converter 
has been added to the Utilities menu. 
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Open the GEOID File Converter program from the Shell by clicking Utilities --> Geodesy --> 
Geoid Generator.

GEOID File Converter Window

Import geoid files by clicking [Select File]. The supported geoid file formats are *.mnt, *.bin, 
*.byn, *.ggf, *.geo, *.grd, *.gra, and *.txt files. You can also import preexisting HYPACK GEO 
files by clicking [Open HYPACK GEO] and selecting from the geoid files in the project's 
\datum folder. If the selected file is an ASCII *.txt file, you will be prompted to select the 
format of the data.

ASCII Format Selection Window
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To export the geoid file, under Export Format select between the HYPACK .GEO File or 
ASCII Text File options. For ASCII Text files, check “Include Geoid data” to export latitude, 
longitude, and separation values. If the “Include Geoid data” option is unchecked, only the 
header will be exported to the *.txt file. You can also add text under File Description, which 
will be written to the HYPACK .GEO file. Click [Export File], select the destination folder, give 
your geoid file a name, then click [Save].
As usual, we strongly recommend testing newly created geoid models before actual use!

TARGET EDITOR
• The Target Editor has received an updated appearance: The Export tab has been 

added, which allows users to select which targets to export to a designated file 
type.

• TXT files can now also be exported directly from the Target Editor by selecting 
“Export to TXT”. If you want to save the targets checked in the tree on the left of the 
editor, select “Checked” under Targets, otherwise select “All” to save all targets. Once you 
click [Export], the Export Targets window will appear. From here, check the variables that 
you would like to save, the type of separator in between each variable, the Latitude and 
Longitude format, and whether to include a column header listing each variable type. You 
can select whether you want to [Print] or [Save] your TXT document.
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You can access the Target Editor from the Shell by clicking Preparation --> Editors --> 
Target Editor.

• Users can now import target text (*.txt) or target (*.tgt) files from the Target Editor 
using the new Import tab. To use this new function, from the Shell go to Preparation -> 
Editors -> Target Editors, then click the Import tab.

Click [Open File], then select the *.txt or *.tgt file with the data you want to import. Once 
the file has been selected, the lower half of the Import tab populates with the details of 
each target within the file.

Next, from the upper left of the Import dialog, check each variable that is included in your 
file. You can click and drag items in the list to reorder them to reflect the order of data in 
your file. If there is extra information that does not match a variable or information you do 
not want to include, click [Add Ignore Field], then check and drag the Ignore label so that 
the list is ordered correctly.

Select the delimiter your file used (comma, space, or tab), and coordinate units (Local or 
WGS84) from the drop down menus. Check the Skip Problem Lines box, then click 
[Check Syntax] to verify if the information you’ve provided in the Import tab matches what 
is in your target file. The message box will inform you how many lines are inaccurate. 

Once you’ve corrected any issues, click [Convert], and your targets will be imported to the 
Target Editor.
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HYPACK HARDWARE
The HYPACK Combined Hardware UI has been redesigned to make setup more 
streamlined, and some new features have been added. An overview of these changes is 
provided below. For more information, check out our article New HYPACK Combined 
Hardware GUI by Andrew Clos from January 2023.

• A Search box has been added to the Mobile tab, allowing users to type and search for 
a driver name.

• You now have the ability to enable, disable, or remove a device by right clicking on 
it.

• HYPACK Combined Hardware now initializes with the first mobile (ie: “Boat”) 
selected with its corresponding Mobile tab displayed.

• A new group of radio buttons at the top of the Mobile tab allows you to switch 
between Survey, HYSWEEP, and side scan devices.

• A few items related to configuring devices, such as the Relative To drop down, 
connection configuration options, and Recording Rate, were in their own separate dialogs 
or on other tabs. These items are now consolidated in the Survey Device tab.

• The [Setup] and [Nav. Stations] buttons have been moved from the Mobile tab to 
the Survey Device tab.

• ln HYPACK Combined Hardware, the Device Connection window has been integrated in 
the Survey Connect tab. Previously, you had to click the [...] button to open the Device 
Connection parameters in a separate window. Our updated Survey Connect tab simplifies 
the setup process.

• Required device functions are automatically disabled and users can no longer 
deselect them. This prevents the user from accidentally turning off these settings, 
resulting in missing data. 
This update currently applies to the following drivers: magnet.dll. In the example 
image below, users cannot uncheck “Depth” and “Record device specific messages” for 
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the Magnetometer Interface.

• Users now have the option to “Use HYPACK Survey timetags” for Klein devices in 
Hardware. By selecting this option, the Klein device will use the time Survey is synced to 
(ie: Veritime, ZDA, 1PPS) instead of the sonar’s timetags.

DRIVER UPDATES
• Subbot.dll: Added the new Terminal Mode option “Pseudo-Differential” to the I/O 

Channels window in the Analog Monitor. To select this mode, after adding Subbot.dll in 
the HYPACK® Hardware setup, open HYPACK® SURVEY --> click [I/O Channels] in the 
Analog Monitor window --> Select Pseudo-Differential from the Terminal Mode drop down 
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menu --> click [OK].

• Gendevparse.dll: Added the Alert Field dropdown, which users can use to select a 
field to set an alert to. Only the enabled values from the Field List will be available in the 
Alert Field dropdown. After selecting the field, users can enter the maximum and 
minimum values to set as triggers for the alerts along with corresponding messages to be 
displayed in the Survey window. Enabling or disabling alerts can be controlled by the 
corresponding checkboxes.
You can open this window by double clicking “Generic Input Parser” from the Hardware 
tree on the left.

We also added the "Record Raw Message" function to the Generic Input Parser 
(gendevparse.dll). When enabled, a MSG tag field is written to the *.raw file with device 
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number, timetag (in seconds past midnight), and parsed data.

• EchoTracE20.dll: The Teledyne EchoTrac E20 driver now supports annotation for 
both channels. In the device window, from the Annotation Channel drop down you can 
choose among annotating both channels, the current channel, or channels 1 or 2.
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HYSWEEP HARDWARE
• We’ve added a driver for the new Teledyne Reson SeaBat T51 to HYSWEEP® 

Hardware. Note that we’ve also updated MBMAX64 to read S7K files from Teledyne 
Reson SeaBat T51.

This driver underwent some changes during 2022. During the initial rollout of the Reson 
SeaBat T51 driver, users had to manually select between 400 kHz or 800 kHz for the 
sonar frequency in the Reson Setup window. The HYPACK 2022 Q2 Update streamlined 
this driver by automating frequency switching even across successive pings. This means 
users no longer need to manually switch frequencies or stop and restart HYSWEEP® 
Survey. Since frequency switching is now automatic, frequency selection has been 
removed from the Reson Setup window, and the following image shows the current 
iteration. This is another reason why it is important to regularly update your HYPACK 
software with each release!
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• Bug Fix - Ross Smart Sweep Driver: Previously, adding multiple transducers from the 
Offsets tab would return an “Invalid Floating Point Operation” error. This issue has been 
fixed, and transducers with multiple offsets will no longer show this error in the 
Offsets tab.

• Added [Set] button to set number of transducers in the Multiple Transducer Offsets 
window. To add multiple transducers, select the device in the HYPACK Hardware 
window --> Click the Offsets tab --> Click [Multiple Transducers] (this button is enabled 
only for certain hardware, ex: the Ross Smart Sweep Driver).

NEW! REMOTE VIEWER
HYPACK Survey Viewer has now been replaced by HYPACK Survey Remote Viewer. 
With this updated program, users can view and control a hosted HYPACK Survey 
screen from remote desktop computers and mobile devices. Viewing devices no longer 
need to have the HYPACK Survey Viewer program installed. Instead, these secondary 
devices now connect to the host computer from the same network. This means any mobile 
device that can connect to the internet with the appropriate browser/support capabilities can 
be used to view and control the hosted HYPACK Survey screen.
For more details on how to configure and use the new Remote Viewer, check out the 
HYPACK Survey Remote Viewer guide.
The general setup process is:
1. Open Remote Viewer and set up remote access on the hosted HYPACK Survey screen 

by clicking Options -> Remote View Over Web. You will need to enable remote access 
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and configure the internal port number, remote credentials, and performance settings in 
the Remote Access window. 

2. Verify that the Remote Viewer has initiated correctly by loading it on the computer hosting 
Survey. In a web browser, type the IP address with port number, and log into the Remote 
Viewer authenticator with the credentials you set up in Step 1.

3. Once you’ve confirmed that Remote Viewer is functioning as intended, log into Remote 
Viewer from a different computer or mobile device. First find the IP address of the host 
computer. In a web browser on a different computer, type in the IP address and port 
number, and log into the Remote Viewer authenticator with the credentials you set up in 
Step 1.
Note that in order to view HYPACK Survey with the Remote Viewer, the host computer 
must be connected to the same network as the other devices.

While the interface has been completely overhauled, Remote Viewer retains the 
original controls that were in the HYPACK Survey Viewer. We’ve also added the data 
toggle button on the right side of the data display, which allows users to show or hide the 
data display and left/right indicators:
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HYPACK Survey Remote Viewer also features a newly designed mobile interface:
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TPU EDITOR
• The WASSP S3 Sonar has been added to the list of multibeam sonars in the TPU Editor. 

When selected, the General tab automatically populates with parameters based on 
published specifications of the WASSP S3.

DATA ACQUISITION

SURVEY
• The [Apply] button has been added to the Navigation Parameters dialog. [Apply] 

applies any changes made by the user and keeps the dialog open and ready for further 
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modifications to be made.

• We’ve added Boat Speed (fps and knots), Ping Rate (Hz), and Average Ping Time 
(sec) to the Device Health window. Users may find these values helpful for maintaining 
an acceptable boat speed to maintain along track data density. To view the Device Health 
window, from the Survey window click Options -> Shared Memory -> Device Health.

• Added the options to export a matrix as an XYZ or GeoTIFF (Esri or RGB style) 
from HYPACK® SURVEY. While running HYPACK® SURVEY, these options will export 
the Survey matrix. To export the matrix from HYPACK® SURVEY, from the Map window 
click the Matrix menu, select either Export to XYZ or Export to GeoTIFF, and a save 
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window appears.

With the Export to GeoTIFF option, you can select between an Esri style or RGB style 
TIFF output.

Within HYPACK® SURVEY, make sure your matrix view is currently set to Survey Depth. 
From the Map window click Settings -> Tracking/Orientation, click the Matrix tab, then 
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from the Show dropdown select the Survey Depth option and click [OK].

• Starting with the HYPACK 2022 Q3 update, RAW files are written with geodesy data 
in the heading. This new update allows users to import geodesy settings into Geodetic 
Parameters from RAW files. See the Geodesy section for more information.

• Added the options to export a matrix as an XYZ or GeoTIFF (Esri or RGB style) 
from HYPACK® SURVEY. While running HYPACK® SURVEY, these options will export 
the Survey matrix. To export the matrix from HYPACK® SURVEY, from the Map window 
click the Matrix menu, select either Export to XYZ or Export to GeoTIFF, and a save 
window appears.

With the Export to GeoTIFF option, you can select between an Esri style or RGB style 
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TIFF output.

Within HYPACK® SURVEY, make sure your matrix view is currently set to Survey Depth. 
From the Map window click Settings -> Tracking/Orientation, click the Matrix tab, then 
from the Show dropdown select the Survey Depth option and click [OK].
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• Starting with the HYPACK 2022 Q3 update, RAW files are written with geodesy data 
in the heading. This new update allows users to import geodesy settings into Geodetic 
Parameters from RAW files. See the Geodesy section for more information.

SURVEY DRIVER UPDATES
• GenDevAll.dll - Added the Correction offset column, which displays the fixed 

correction applied to each row. View the Survey Driver window by opening HYPACK® 
and clicking Preparation -> Hardware Setup and add gendevall.dll to your Hardware list. 
Double click the added HYPACK Configurable Device Driver.

• NMEA.dll - Added new check box to allow parsing of XDR NMEA sentences in the 
NMEA Input/Output Driver Setup window. High frequency and low frequency depths 
are parsed and displayed in the Data Display window of survey. They are also logged in 
the RAW file as EC2 (dual frequency) depth records. You can select this option by going 
to Preparation -> Hardware Setup, add nmea.dll, then double click the driver to bring up 
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the setup window.

Note that the default depth values are output in meters, therefore we convert this data to 
feet when using a foot grid in Geodesy.

• NMEAOutput.dll - Added the option to output ZDA data. Choose from the following 
four output conditions: Never, Always, While Logging, and On Event Only. View the 
NMEA Output window by opening HYPACK® and clicking Preparation -> Hardware Setup 
and add NMEAOutput.dll to your Hardware list. Double click the added NMEA Output 
device in the Hardware tree view.
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• Tidetrac.dll - Added Device Alarm Timeout option to the eTrac Tide Gauge driver. 
Errors will not play the alarm sound unless the designated amount of time passes.

• Posmv.dll: In the Applanix POS M/V Setup, we’ve added the Use GSOF Messages 
checkbox. When enabled, the Solution Status box changes to the Data and Solution 
from Message box, and shows the GSOF messages and corresponding code. Select the 
navigation message you would like to obtain your data and solution from. Default is to use 
INS Sensor 1 Nav #65.

With the new Trimble AP+ Air and Land devices, Applanix are moving away from using 
their old group codes towards outputting raw Trimble GSOF messages. For setup, check 
out our article Logging with New POS AP+ Devices in HYPACK written by Ken Aiken from 
January 2023.
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DREDGEPACK
• Added the options to export a matrix as an XYZ or GeoTIFF (Esri or RGB style) 

from DREDGEPACK®. While running DREDGEPACK®, these options will export the 
dredge matrix. To export the matrix from DREDGEPACK®, from the Map window click the 
Matrix menu, select either Export to XYZ or Export to GeoTIFF, and a save window 
appears.

With the Export to GeoTIFF option, you can select between an Esri style or RGB style 
TIFF output.

Within DREDGEPACK®, your selection will export the currently selected matrix view 
(Dredge, Survey, Survey-Dredge). To check or change which matrix view is currently 
displayed, from the Map window click Settings -> Tracking/Orientation, click the Matrix 
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tab, then from the Show dropdown select your depth display option and click [OK].

• The Bucket Dredge Setup dialog has been updated with a few new features:

> The Show Guide Bucket checkbox has been added, which shows where a bucket 
will be placed as the mobile moves.

> The Use Shape File option has been added. Users may want to use a bucket shape 
that is different from the default rectangular buckets. Enabling this option allows users 
to upload a *.SHP file that contains a custom bucket shape.
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> Similar to regular buckets, shape file buckets can also have hashed or solid fills. 
You cannot change the size or scale of the shape in DREDGEPACK.

> In Real Time Cloud, users can now enable buckets to be drawn as they are 
dropped. As part of the changes to bucket placement, we've added the 
BUCKET_INFO shared memory area that updates to the last marked bucket. This 
allows Real Time Cloud receive bucket file updates and display a 3D object at the 
bucket location.

Open Real Time Cloud by first opening DREDGEPACK, then click Options --> Shared 
Memory --> HYPACK Real Time Cloud.
To enable drawing buckets in the Real Time Cloud, click View --> Settings to open the 
Settings window. In the General tab, select the bucket type from the Buckets drop 
down. Custom shapes (*.obj, *.3ds, *.3od) can be used by selecting Custom and 
opening the 3D Shape File. 

> Pressing F3 in Real Time Cloud marks the bucket in Survey.

DREDGEPACK DRIVER UPDATES
• DQM_Mechanical.dll - Added Boom Angle Offset to the Settings window. For cranes 

with an irregular boom, users can now specify the value of the Boom Angle Offset, which 
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is added to the measured boom angle.

• New Driver: AutoBucketMark.dll. - Users can auto-mark buckets based on depth 
and bucket open/close percentage. This is only known to work with 
DQM_Mechanical.dll.
To set this up, make sure the Output functionality is checked in Hardware Setup.

From the runtime window you can enable/disable the Auto Bucket Mark mode. The 
options are: Depth Greater Than, Depth Less Than, and Open/Closed Percentage Less 
Than. You can also choose if you want to use the raw or corrected depth for comparing to 
the depth options.

• DQM Mechanical Driver (DQM_Mechanical.dll): 
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> Added the Cashman Crane System option. This option works the same as the 
HYPACK Crane System V2, however users can set the bucket depth to 0 at any 
boom angle for a Cashman crane system.

> DREDGEPACK® now retains the cable/wire count after closing and reopening 
the program.

• Excavator.dll: Telestra MCAS devices using PEAK or Ixaat CAN bus connectors are now 
supported and connect automatically.

• HD25A.dll: Changes were made to update interface and stabilize driver performance.

• Inclinometer.dll:
> Added support for Telestra MCAS devices and Allen Bradley PLC.
> For Telestra MCAS devices, the Telestra tab in the inclinometer.dll Setup 

window now includes options to specify swing sensor parameters as well as 
set up a Sway Alarm.
To view this setup window, add inclinometer.dll in HYPACK Hardware, click the 
[Setup] button, then in the Main Settings window select Telestra as the Instrument 
Type to add the Telestra tab.

• Added TelestraPR.dll: This is new a pitch/roll only driver for the Telestra MCAS devices. 
Previously you had to use a second instance of Excavator.dll to obtain pitch/roll.
40



HYSWEEP® SURVEY
• Added File Size Limit (MB) field to the Logging Options window (File --> Logging 

Options).

> Use it to set the maximum allowed file size when logging data. This value must 
be at least 10 MB. A reminder about the 10 MB file size minimum will be displayed if 
the value entered is less than 10 MB, and the program will also automatically change 
the value to 10 MB. 

> While logging, once the maximum file size limit has been reached, the program 
automatically restarts logging in a new file.

> Note that actual HSX files will be slightly larger than the entered file size limit because 
HYSWEEP® SURVEY ends logging a couple of seconds after the limit has been 
reached.

> Enter 0 if you do not want to limit the logging file size.
• A couple of new updates for NORBIT devices:

> Added “Send Start/Stop Logging Commands” option to hardware setup 
window for NORBIT Dual Head and WBMS devices. When enabled, start/stop 
logging messages are sent from HYSWEEP® Survey to the NORBIT device.

> HYSWEEP® has been updated to support NORBIT yaw-stabilized multibeam 
sonars (WINGHEAD i80s and i87s). HYSWEEP® now processes this data to show 
accurate real time displays and matrix fills.
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HYSWEEP DRIVER UPDATES
• The Picotech PicoMBES driver has been updated. Some things to note:

> The network setup has been simplified by hard coding driver receive (sonar data) so it 
is fixed at 10.0.100.70:13000, and driver send (settings to sonar) is fixed at 
10.0.100.120:9000.

> The minimum ping rate limit is 2 Hz.
• Kongsberg EM 

sonars that 
output KMALL 
datagrams now 
use the 
Kongsberg 
KMALL device 
driver in 
HYSWEEP 
Hardware Setup. 
KMALL 
datagrams include 
SIS 5 data or data 
directly from the 
stand alone K-
Controller. You will 
need to use the 
Kongsberg KMALL device driver for EM2040, EM712, and EM304 systems.

The new procedure is: 
From the Shell, click Preparation -> Hardware Setup. In the HYPACK Combined 
Hardware window, click Hardware in the left tree view and check the Include box under 
HYSWEEP Survey. This adds HYSWEEP Survey to the devices in the left tree view. Click 
HYSWEEP Survey, then click and [Add -->] the Kongsberg KMALL device.
Double click Kongsberg KMALL to open the setup dialog.

> Connection Mode: Choose between UDP, UDP Multiport, or TCP Multiport.
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> Reverse Raw Beam Angles: Enable this option for reverse-mounted sonar.
> Log Datagrams (.kma): Enable to log received KMALL datagrams to file. The logged 

file will be similar (if not identical) to Kongsberg KMALL file logging.
> Log water column: Will be added in upcoming update.
> Device Name: EM device name from K-Controller. Required for initial connection.
> K-Control / SIS IP address: Required for initial connection.

> HYSWEEP saves Kongsberg configuration to kmall_iip_hysweep.txt (installation 
parameters) and kmall_iop_hysweep.txt (runtime parameters) in the project folder. 
These can be useful for troubleshooting and post-processing.

Prior to the HYPACK 2022 Q3 update, HYSWEEP Hardware setup for the Kongsberg 
EM 2040 sonar required users select the Kongsberg Simrad EM2040 device driver 
and check the Use KMALL Format box in the Kongsberg Setup window. Starting with 
the HYPACK 2022 Q3 update, this option is no longer valid and the KMALL checkbox 
has been removed.

> Added the Invert Pitch option for iXBlue IMU Serial, UDP, and TCP devices in 
HYSWEEP. Checking Invert Pitch will give pitch values matching the TSS standard 
(bow up positive), which is what HYSWEEP expects.
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• Added the Hydro-
Tech MS400 
multibeam driver. To 
use this driver, open 
HYPACK® and click 
Preparation -> 
Hardware Setup to 
open the HYPACK 
Combined Hardware 
window. While 
Hardware is selected 
in the left tree view, 
from the System tab 
click the Include box 
under HYSWEEP 
Survey. HYSWEEP 
Survey will be added 
to the left tree view, 
and you can select the 
Hydro-Tech MS400 
from the list in the 
Multibeam Devices 
tab.

A few other things to 
note for the MS400. 
The Hydro-Tech 
MS400 sends 
R2Sonic format 
datagrams for Bathy and TruePix, and our driver decodes the TruePix as a digital side 
scan. Regarding connections for the Hydro-Tech MS400, use the UDP network interface 
and port 8005 for sonar data. Use the HYPACK® and HYSWEEP® drivers for Applanix 
POS MV to receive position and motion data with port 5602.

• Applanix POS/MV Network driver: The Applanix Setup window for HYSWEEP 
Survey is simplified, and consolidates all group codes and GSOF codes in one list. 
Default is to use GSOF #65.

With the new Trimble AP+ Air and Land devices, Applanix are moving away from using 
their old group codes towards outputting raw Trimble GSOF messages. For setup, check 
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out our article Logging with New POS AP+ Devices in HYPACK written by Ken Aiken from 
January 2023.

SIDE SCAN SURVEY
• Added the new AGC (Angle Gain Correction) gain option to Side Scan Survey. In 

Side Scan Survey, go to View -> Options -> Gain and select AGC from the dropdown. 
AGC calculations use a rolling average of your side scan data, from the start of your 
survey. The “Reset” button resets the AGC calculation’s rolling average. Adjust sliders in 
the main Sidescan Survey window to get a good image. Note that in the main Sidescan 
Survey window, Toggle TVG Mode icon will read “Auto2” when AGC is selected.

• Users can now set up the Analog Monitor in Side Scan Survey to send a trigger to 
their analog device when survey events occur. The Event Output option has been 
added to the I/O channels window. Set this to the analog output you want your triggers to 
go out.

To send triggers on a survey event:

1. In HYPACK Hardware, add Subbot.dll and enable “Paper annotation” under Options.
2. Launch Side Scan Survey.
3. In the Analog Monitor window, click [I/O Channels] to open the I/O Channels window.
4. Enable Event Output and from the drop down select the analog output you want to 
February / 2023  45



send your triggers and click [OK].

5. In the Analog Monitor window, click [Trigger Configuration] to open the Trigger 
Configuration window. You will set up a trigger configuration to use the event output.

6. Set Trigger Mode to Survey Event.
7. The Trigger Length option sets how long you want the trigger to output when a Survey 
Event happens.
8. Configure the remaining settings like normal. Click [OK].
9. Click [Apply] in the main window.

Survey events now create an output trigger.
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• The Side Scan signal graph now automatically updates when switching between 
gain types to give users better signal visualization and better initial colors.

KLEIN MA-X VIEW 600 SUPPORT

HYPACK now supports the Klein MA-X View 600 Side Scan sonar, which is Klein’s 
revolutionary new nadir gap-filling sonar. The MA-X View 600 provides vastly improved 
nadir coverage by augmenting its side scan sonar with a forward-looking center channel 
sonar. This new integration includes the following features:
• A new driver named ALSLib20_32.dll, which must be included for the MA-X View 600 

to work. This driver is included in the HYPACK 2022 Q2 release files.
• Users will add and set up the Klein MA-X View 600 from HYPACK Combined Hardware 

under Side Scan Devices.
• The center channel data is viewable in HYPACK Survey in the Side Scan Waterfall 2 

window.
• Users can choose to display the entire range of the center channel or view only the 

default range.
• QC Display shows the fish’s altitude, pitch and center channel’s “lookahead” direction.
• Targeting in center channel is fully supported.
• MA-X View data can be post-processed in HYPACK using normal workflows.
For additional details on how to use the Klein MA-X View 600, check out:
• Our article on getting started with the Klein MA-X View 600
• HYPACK’s integration announcement: 

https://www.hypack.com/about-hypack/blog/hypack-news-blog/2022/06/ma-x-view-600-
in-hypack

• Specifications for Klein MA-X View 600:
https://mind-technology.com/klein/klein-ma-x-view-600/

KLEIN MA-X VIEW 600 - LOOKAHEAD CHANNEL DATA

The MA-X VIEW 600 has a center channel that “looks ahead” of the sonar. HYPACK® 
logs this information to the HSX file as an LAH record.
Lookahead data is tagged as LAH, and data format is:
LAH dn t a d
where:
dn: device number
t: time tag (seconds past midnight)
a: depression angle of lookahead sonar (in decimal degrees, positive down)
d: lookahead distance to bottom (in meters)

SURVEY LOG
• Added functionality to load survey log data with header info from the previous 

session. When the Survey Log program is launched, users are prompted to choose if 
they want to load the survey log data from the previous session (“Do you want to load 
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previous session data?”). Select [Yes].

• Changed exit question to “Would you like to export survey log before exiting?” 
When exporting the survey log, the default file extension is *.PDF.

SINGLE BEAM PROCESSING

SB SELECTION

• The SB Selection program is now updated with modern icons and forms. See below 
to compare the old (top image) and new (bottom image) interfaces.
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POST-PROCESSING

64-BIT SINGLE BEAM EDITOR (SBMAX64)

NEW FILE FORMAT SUPPORTED IN SBMAX64
• Teledyne’s S7K files. Users can load multiple S7K files simultaneously.

Starting with the HYPACK 2022 Q2 release, SBMAX64 also calculates RTK tide values 
from S7K files and applied these values to the corrected depth in the Spreadsheet 
window. 

As part of standard file processing in SBMAX64, if you have logged RTK tide corrections 
in SURVEY and you want to apply them in your editing session:
1. Click File -> Read Parameters to open the Read Parameters window.
2. Go to the Devices tab and select one or more files from the list.
3. Click [Edit] and check the RTK Tides checkbox. Click [OK].
This calculates RTK tides from the S7K file and applies it to the corrected depth in the 
spreadsheet.

NEW FEATURES IN SBMAX64
• We’ve added the Remove Duplicate POS Records check box, which allows the user 

to remove duplicate consecutive POS records. Sometimes a GPS outputs the same 
POS value to HYPACK across multiple consecutive timestamps. This option only retains 
the first POS record.
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To select this option, open SBMAX64, and select the files you want to process from the 
Catalog window. The Read Parameters window will appear, and in the Devices tab, click 
[Edit] which opens the Device Offsets window. You can check or uncheck the Remove 
Duplicate POS Records and click [OK].

• The Presort filter has been added to SBMAX64. Similar to the Presort tab in the Single 
Beam Editor, SBMAX64's Presort allows users to presort based on user-defined 
parameters, and reduce the amount of data that needs to be edited. The data is first 
divided into sections based on a user selected parameter and increment, then the 
selected depth value (first, min, max, or average depth) from each section is kept in the 
spreadsheet for processing. By using this filter, users can prevent the possibility of 
unintentionally saving data spikes rather than valid data. 

To use Presort, in SBMAX64 click Tools --> Presort to open the Presort window.

The options are the same as Presort in the Single Beam Editor Read Parameters. Users 
set which data to apply the presort filter to, the basis on how the data is divided into 
sections and the increment, and which depth value to use from each section. After 
presorting, all depths that have been filtered out are marked with "*****" in the 
Spreadsheet.

Because Presort is a filter, this function can be used, modified, and reverted with the 
Undo button.

• When loading files, a warning message now appears if device offsets have been 
changed in the raw file(s). This message displays the file name of the first discrepancy.
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• Bug Fix: Changes to the Latency value in the Device Offsets window are now 
applied to the Spreadsheet.

• Added the Device Time Shift Window. Located under Tools -> Time Shift, the dialog 
lists the possible devices to time shift, an edit box to enter the shift to apply, and their 
current shift in seconds.

• Added the Uninterpolate button - On the first click, it marks uninterpolated points on the 
line as light blue “X”s and the button turns light blue, and on the second click reverts 
points back to their interpolated values and the button turns grey again.
> To keep the uninterpolated values, click Edit -->Undelete and Reset to reset the 

current uninterpolations for either the single current line or all lines.
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> Points interpolated with filter are included in uninterpolations.

BUG FIXES IN SBMAX64
• Modified the Read Parameters window so that changes to the VEL file and 

Echosounder Setting value are now applied to a loaded Survey.
> Note that the Echosounder Setting is only modifiable when a VEL file is loaded.
> Certain SonTek M9 HS2x files already have SVP tags within them. For these files, 

users will be able to modify the Echosounder Setting value when the Survey is first 
loaded. After the Survey is loaded, if Read Parameters is opened again or the HS2x 
file is saved and reopened, the Echosounder Setting will no longer be modifiable. For 
HS2x files that do not have SVP tags, Echosounder Setting will continue to be 
modifiable.

> When selecting a range of files with different Echosounder Setting values, it will show 
the minimum and maximum values entered for those files.

Additional error checking messages have been added to the Echosounder Setting:
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> A dialog will appear if the Echosounder Setting value entered is outside of the 
1400 m/s to 1600 m/s range (4593.2 ft/s to 5249.3 ft/s). Select [Yes] to reset to the 
suggested value, select [No] to use the value entered in the Echosounder Setting.

> If user enters a value from 1400 to 1600 in the Echosounder Setting field when 
units are in ft/s, a dialog will appear asking if the user wants to convert the 
value from feet to meters. Similarly, when a value from 4593.2 to 5249.3 is entered 
when units are in m/s, the dialog will ask if the user wants to convert the value from 
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meters to ft. Select [Yes] to convert the value, select [No] to use the value entered in 
the Echosounder Setting.

64-BIT HYSWEEP EDITOR (MBMAX64)

NEW FILE FORMATS SUPPORTED IN MBMAX64
• S7K files from Teledyne Reson SeaBat T51.
• Kongsberg KMALL bathymetry and side scan data.

NEW FEATURES IN MBMAX64
• Users can now use the newly added Overlay check boxes to overlay depths in the 

Profile and A-B Cross Section Windows if a filled matrix is selected in Read 
Parameters. When overlay depths are available, users can check or uncheck the 
Overlay check box to show or hide them. The overlay depths are displayed as a solid line 
on top of sounding points.

To use this new feature:
1. Select a filled matrix in Read Parameters. 
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Start by clicking the Read Parameters icon.  
Under the Matrix box in the Survey tab, click [Edit...] to bring up the Matrix Settings 
window. Select “Use HYPACK MTX File” and open the filled matrix file. Click [OK].

2. Open the Profile window and check the Overlay box to display the overlay depths 
(white line).

3.The Overlay option is also available in the A-B Cross Section window and displays in a 
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similar way.

• Raw Depth is now displayed in the Sounding Info and Sweep Windows. Raw depth 
is the corrected depth or elevation value without tide (water level) correction.

In Depth mode: Raw Depth = Corrected Depth - Tide Correction.
In Elevation mode: Raw Depth = Tide Correction - Corrected Elevation.

The following image is an example in Depth Mode with -5' tide correction (+5' tide). Z is 
the corrected depth.

This image is an example of Elevation Mode with 100' water level correction (also termed 
tide correction). Z is the corrected elevation.
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Raw Depth is now also displayed in the Sweep window.

• For Reson systems, Absorption Loss and Spreading Loss are now displayed in the 
Sounding Info window under Sonar Settings. Note that this requires HSX logging with 
HYSWEEP 22.1.4 or higher, as previous versions did not log Reson ocean settings.

• Added the Go To Position function, which allows users to move their cursor to a 
sounding by entering an X/Y position or Latitude and Longitude coordinates. 

To use this function:
1. Open MBMAX64, load and perform Stage 1 editing on your data, then advance to 
Stage 2 processing by clicking File -> Stage 2 (Depth Editing).
2. From the top toolbar, click View -> Go To Position to open the Go To Position display. 
The display initiates with the current coordinates of the cursor in the list box on the right. 
X/Y are shown in feet or meters depending on the working units, and Latitude and 
Longitude are show in decimal degrees. 
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In the example below, the initial cursor position and X Y coordinates are boxed in blue.

3. Enter new values for X and Y (or Longitude and Latitude), then click [Add]. The cursor 
will move to the sounding at or closest to the newly entered location, and add the new 
coordinates to the list box.

Note that [Up] and [Down] are enabled after a new set of coordinates are added to the list of 
positions with [Add]. Clicking [Up] or [Down] will move the cursor to the previous or next 
location in the list, respectively. If multiple locations have been added, [Up] and [Down] 
function similarly to the "Undo" and “Redo” features and cycle to previous or subsequently 
added positions. Once the cursor has reached the first position, [Up] will be disabled.
58



The list of coordinates will also include Target locations and descriptions if the 
Targets check box is selected in the top menu under Show. Targets will not be displayed 
if Targets is unchecked. 
In the example below, three targets (white dots) are displayed on the MBMAX64 map and 
shown in the Go To Position coordinates list (blue box).

• Auto Save HS2x has been added to the Save Reminder options. When properly set 
up, the 64-bit HYSWEEP® EDITOR automatically saves or prompts users to save any 
changes made during Stage 2 editing to the HS2x file(s).

To set up Auto Save:
1. In the 64-bit HYSWEEP® EDITOR (MBMAX64) you must start Stage 2 editing, then 
click File -> Save Survey -> [Save Reminder/Auto Save HS2x...] to open the Save 
Reminder/Auto Save HS2x window.

2. Check the box next to Enable.
3. If you want an auditory alarm to sound when your file is auto-saved, check the box next 
to Beep. While this is checked, the Windows Background noise will occur at the 
designated time interval to remind you it is auto-saving.
4. In the Minutes box, enter the time interval at which you want your files to be autosaved 
or be reminded to save them. This value must be an integer of 1 or greater.
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5. Click the Auto Save HS2x button. Auto Save HS2x automatically saves changes you 
have made to the corresponding HS2x files after the user-defined time interval has 
elapsed after the first edit.

If you want to manually choose which HS2x files to save, check the Overwrite Prompt 
box. While Overwrite Prompt is checked, a prompt window appears at the designated 
time interval after the first change is made to ask if you want to save your edits by 
overwriting the HS2x file(s). For example, if you designate an Auto Save time of 1 minute, 
if you open Stage 2 editing at 2:00 PM, grab some coffee and begin editing at 2:05 PM, 
an Overwrite Prompt will appear at 2:06 PM.

The Overwrite Prompt window displays the HS2x file name, and offers several save 
options:
> [Yes] saves the changes to the displayed HS2x file. If you save using this method, the 

window will cycle through each file listed on the left, allowing you use [Yes] or [No] to 
save or ignore changes made.

> [Yes to All] batch saves the changes made to all HS2x files that are listed on the left. 
> [No] does not save changes made to the HS2x file whose name is displayed in the 

window. If you save using this method, the window will cycle through each file listed 
on the left, allowing you use [Yes] or [No] to save or ignore changes made.

> [Cancel] does not save changes made to all HS2x files listed on the left.

If [No] or [Cancel] are selected, users will be repeatedly prompted to save at every 
user-defined time interval, even if no changes are made, until the changes are saved.

If no changes are made within the editor, the prompt will not appear. The overwrite 
prompt will appear or auto save will occur X minutes after the first change is made.

• Added the option to batch autosave HSX files to HS2x when loading files logged by 
a survey program (ex: HSX, S7K, KMALL, multi-transducer RAW files). 
This update helps with save speeds when processing data in MBMAX64. The HS2x 
format files are loaded and saved much faster than HSX files. By loading HSX files then 
autosaving to HS2x, users can edit and save the HS2x files more frequently without a 
significant loss in time waiting for files to save.

To Auto Save HSX files to HS2x:
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1. When loading HSX files in MBMAX64, in the Read Parameters window, go to the 
Survey tab and check the boxes next to Auto Stage 2 and Auto Save and Exit, then 
click [OK].

> MBMAX will apply all the corrections and settings selected in Read Parameters and 
save the data automatically into the Edit folder of your project as HS2X files.
> Overwrite prompts will appear for HS2x files that already exist.
> The Auto Save and Exit checkbox is disabled when loading HS2x files, since it makes 
no sense to load from HS2x then immediately overwrite the file.

2. When the conversion is finished, you will receive an alert message that says 
“Complete”. Click [OK] and MBMAX64 will close.
3. Reopen MBMAX64 and click the Load Survey icon. In the file explorer, open the 
Edit folder to open the HS2x files you saved.

• Added a new option to filter matrix cells based on the minimum number of 
soundings per cell. For example, if the minimum number of soundings per cell is set to 
three and a cell contains only two soundings, both soundings will be filtered out.
To filter a matrix by setting the minimum number of soundings per cell, click Edit -> 
Search and Filter Options. Check the box next to Minimum Number of Soundings Per 
Cell, then enter the number in the box below. Click [Update Filter Preview] to apply the 
new rule to the matrix.

FEATURE DETECTION IN THE 64-BIT HYSWEEP EDITOR
Bug Fixes:
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• The Save button was enabled before features were detected. No XYZ. This resulted in 
bogus detections being saved. The Save button is now enabled after the first feature 
is detected.

• The Export Targets button was disabled when Feature Detection is first started. Now the 
Export Targets button is enabled once the first feature is saved.

Improvements:
• The Feature Information section has been reorganized to read easier.
• Detections are now classified as "FEATURE" instead of "OBSTRUCTION". 

Obstruction didn't make sense for detections below grade or outside the channel.

• Export to Targets now shows how many targets are saved and how many are 
skipped. Export is skipped for detections already saved as targets (using a 1 meter 
distance check), this avoids duplicates.

SIDE SCAN TARGETING AND MOSAICKING
• In Phase 3 of Targeting and Mosaicking, you can now select which frequency you 

want to mosaic from the Frequency drop down box. To use this new feature, from the 
Shell click Side Scan -> Targeting and Mosaicking, then from the Side Scan Mosaic 
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window click Mode -> Mosaic. In the Mosaic window make sure you are in the General 
tab, then select from the Frequency drop down.

NEW: TARGETING AND MOSAICKING (BETA)
HYPACK® 2023 includes a new version of our Side Scan Targeting and Mosaicking program 
with an updated UI. To access it, open HYPACK® 2023 and click Side Scan --> Targeting 
and Mosaicking (Beta).
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This beta version of our Targeting and Mosaicking program collects all the separate windows 
in the original Targeting and Mosaicking and displays them in one UI.
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SIDE SCAN MERGE MOSAICS

• The minimum supported resolution is now displayed below the Resolution box in 
the Merge Mosaics window. Users must enter a resolution that is equal to or higher than 
the minimum supported resolution.

FINAL PRODUCTS

HYPLOT MAX
• When a title block is frozen, the title block container as well as its text boxes can no 

longer be moved or resized, even if the text boxes do not have a lock icon next to 
them in the tree view.
Remember you can add title blocks in HYPLOT MAX by clicking Add -> Block, then 
selecting a block file (*.htb) from the list. The title block and all nested text boxes will 
appear on the plotting sheet and the Items tree view on the left. To lock the title block, 
right click on its name in the tree view, then click Frozen. A lock icon will appear next to 
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the name of the title block.

• Users can now specify the number of divisions on a scale bar. To set the number of 
divisions, click the name of the scale bar from the Items tree view, then go to Properties 
and enter a number from 1 to 8. The scale bar will be drawn with the entered number of 
segments.

EXPORT
• Added GeoJSON to the list of export options within the Export program. The following file 

types can currently be converted to a GeoJSON:
> ALL (RAW) files (tracks and soundings)
> BRD/Border files
> HS2 (tracks only)
> HS2x files (tracks and soundings)
> LNW files
> SWP (tracks and soundings)
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> Targets
> XYZ files

To use this option, from the HYPACK Shell click Final Products -> Export to open the Export 
window. Under Output File, click the Format dropdown and select GeoJSON File.

Give your GeoJSON file a name by clicking the Browse icon next to the Name field, navigate 
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to the folder you want to save to, type in a file name you want to save to, then click [Save]. In 
this example, <Export Halifax WGS84.geojson> is the file name.

Click [Options], then select GeoJSON Output on the left to bring up the output settings. You 
can choose to export your data as Easting/Northing (XY), Local Lat/Lon, or WGS84 Lat/Lon. 
Click [OK] to confirm your desired output settings.

Back in the Export window, select/deselect the Data Files and Project Files you want to 
convert by checking/unchecking the check box next to each file name. Click [Convert] to 
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convert all of the selected files within your project to the specified GeoJSON file. The 
conversion log will list all files converted.

The GeoJSON consecutively lists all the selected converted files and their data. In the below 
excerpt from the GeoJSON generated in this example, you can see that the data for 
HalMtxSurveyDep.xyz is followed by Hal.brd.
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ENC EDITOR
• The Display Geometry option now defaults to ON when the ENC Editor is initialized, 

so points and chains remain displayed on the chart after they are created. 
Previously, Display Geometry was OFF by default. This led to some confusion where 
chains and points would not be displayed after creation, however users had to click ON 
the Display Geometry option to view these objects. Now, to hide these points and chains, 
just click Display Geometry to toggle it OFF.

• The ENC Editor has also been updated with modern icons and forms (see above 
image).

UTILITIES

ADCP PROFILE
• The ADCP Profile window has received a visual update:

> Moved tabs into dockable windows and created a side bar with buttons and options.
> Moved a lot of things out of the options dialog into their relevant windows so that it's 

easier to see what you are doing.
> Redid the survey view drawing so it shows you what you'd see in the 2D exports.
> Added Boat Speed vs Water Speed window for User QC purposes.
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> Added ability to correct mag dec in options. Can calc from file lat/lon.

> Added options to create DXF exports of the profiles with 2 different output methods: 
One for vertical profiles similar to what you see in the profile window, the other for 
horizontal slices of the profiles at set depth intervals. These are saved into the ADCP 
folder of the project.

> Improved Contour Dialog and now will give feedback when done. Also fixed issue 
where Contour Dialog could failed to create a contour if the TIN had holes.

• If multiple cross sections/profiles are loaded in the ADCP Profile window, the 
“Save to CSV” function now automatically saves all profiles to individual *.csv 
files. Users no longer need to save each individual profile one by one. 

To save the loaded ADCP profile(s), click File --> Save to CSV --> Navigate to the folder 
you want to save your file(s) --> Click [Select Folder]. Each *.csv file is created using the 
name of its corresponding *.adp file.

In the following example, after selecting “Save to CSV” and the folder EDT06262018, the 
five profiles loaded in the ADCP Profile window are all automatically saved to the 
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designated folder.

• Similarly, if multiple cross sections/profiles are loaded in the ADCP Profile window, 
the “Save to Excel” function now automatically saves all profiles to a single *.xls 
file with one profile per sheet/tab.

To save the loaded ADCP profile(s) to an *.xls file, click File --> Save to Excel --> 
Navigate to the folder you want to save your file(s) --> Type in a file name --> Click [Save]. 
The *.xls file will be created, and each sheet in the file will be named after its 
corresponding *.adp file.

In the following example, after selecting “Save to Excel” and naming the file 
ADCP_EDT06262018.xls, the five profiles loaded in the ADCP Profile window are all 
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saved in the *.xls file with one sheet per profile.

• Users can now auto scale colors from the main ADCP Profile window instead of 
from the Options menu. The ADCP Profile toolbar now has an auto scale drop down, 
which allows users to set the color scale to No Scaling, Scale All Files, or Scale Current 
File. Additionally, the Auto-Scale Colors checkbox is removed from the Profile View tab in 
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the Options window.

• We’ve added an Intensity value display to the Information window. In addition to 
other ADCP Profile data (ie: Bin data, heading, pitch, roll, etc), this window now 
shows intensities in different locations of the ADCP Profile.
To open the Information window, from ADCP Profile click View -> Information (or use 
CTRL + I). Make sure the Profile tab is selected in the ADCP Profile window. The data in 
the Information window, which includes the new display of Intensity values, will update as 
you move your cursor around the profile.

• Users now have the option to save Beam Intensity values to XYZ Intensity (XYZI) 
files. To do this, in the ADCP Profile window click File -> Beam Intensity to XYZI. Save 
Current Line exports the beam intensities of the currently selected file to an XYZI file, and 
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Save All Lines exports beam intensities of all loaded files to multiple XYZI files. The XYZI 
files can be loaded into Cloud to visualize the signal to noise along the track.

TIDE ANALYZER
• Added the Smoothed Tide value and its Deviation to the status bar of the Tide 

Analyzer window. This Deviation is calculated as the Smoothed Tide value (boxed in 
red) minus Tide File Tide value (boxed in blue).

Bug Fixes:
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• The popup descriptions for the Remove Below and 
Remove Above line icons now display correctly and are 
no longer swapped.

• Fixed an issue with zooming in when the data doesn’t start at 
midnight. 

CROSS SECTIONS AND VOLUMES

JACKSONVILLE POST-DREDGE METHOD

• Users can now display a box cut overlay in the Jacksonville Post-dredge method. 
Box cut extents are drawn as dashed lines.
The dashed lines represent the box cuts in the following image, where the left box cut is 
set to 50 and the right is set to 10.

> To add the box cut overlay, go to Graph Options tab --> Labeling tab --> in the 
Annotation section, check “Inflection Points”.

Box Cut Overlay
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Also, make sure to go to the Volume tab and check the appropriate Jacksonville 
Setup parameters:
• If B Material Calculation Option is “Post Dredge Below Overdepth / First Void 

Only”, no lines are drawn for B but the fill is displayed.
• If “Ignore Sideslope” is checked, no lines or fills are drawn.
• If the selected Credit Calculation uses B, the lines for B are drawn and B fill is 

displayed.
• If the selected Credit Calculation uses C, the lines for C are drawn and C fill is 

displayed.
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Bug Fixes:
• The Jacksonville Post-dredge method now correctly fills in the X1 Right area on the 

graph.
• Min(A,C) no longer displays B area and no longer shows B volumes in report.
• Updated Fill Color icons to properly display selected colors.

CLOUD
• A new Save Dialog in HYPACK CLOUD consolidates the Save, Save As, and Save 

to XYZ options. Just click the Save File icon to bring up the Save Dialog window. From 
this new dialog, you can select the file type (XYZ, LAS, LAZ, PTS, MTX, or ASC), choose 
whether to include intensity or RGB coloring, and save your data as a single file, 
individual files, or save with the original file’s name. 

• The New Save Dialog supports saving RGB and Intensity to an XYZ file when the 
CLOUD grid is used.
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• Added the new Target View dialog in CLOUD, which displays all targets and targets 
group in a tree view. Users can toggle them on or off, and select how the targets are 
drawn by right clicking on them.

• Under File --> Load 3D Charts in addition to bucket files you can load DXF and DGN 
charts. They will be added the File View panel and drawn with the XYZ data loaded. You 
can unload and disable them by right clicking on them in the File View like you would for 
loaded point files as well. 
NOTE: This option is intended for shoreline-type background files and contour lines. This 
option is NOT intended for color fills!

• Bucket Files are now loaded into CLOUD. They can be loaded by clicking File --> Load 
3D Charts. They then appear in the file view dockable pane. If you right click on the 
bucket file there, you can select how it is colored and its shape with two built-in shapes 
and a option for a custom shape loaded (*.obj, *.3ds, or *.3od). If you have more than one 
bucket file loaded it will ask if you want to apply these settings to all your loaded bucket 
files. You aren't required to load any XYZ files to display them.
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